Silly test trying to cross-compile a working gentoo prefix install for Termux on Android (aarch64)
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

66 lines
2.1 KiB

diff --git a/app-admin/eselect/eselect-1.4.20.ebuild b/app-admin/eselect/eselect-1.4.20.ebuild
index 338c3aba0..63490c9b4 100644
--- a/app-admin/eselect/eselect-1.4.20.ebuild
+++ b/app-admin/eselect/eselect-1.4.20.ebuild
@@ -26,6 +26,13 @@ BDEPEND="doc? ( dev-python/docutils )"
PDEPEND="emacs? ( app-emacs/eselect-mode )
vim-syntax? ( app-vim/eselect-syntax )"
+# https://bugs.gentoo.org/905934
+src_configure() {
+ econf \
+ ac_cv_path_BASH="${EPREFIX}/bin/bash" \
+ ac_cv_path_ENV_UPDATE="${EPREFIX}/usr/sbin/env-update"
+}
+
src_compile() {
emake
use doc && emake html
diff --git a/dev-libs/gmp/gmp-6.2.1-r5.ebuild b/dev-libs/gmp/gmp-6.2.1-r5.ebuild
index 585425499..a32e1c107 100644
--- a/dev-libs/gmp/gmp-6.2.1-r5.ebuild
+++ b/dev-libs/gmp/gmp-6.2.1-r5.ebuild
@@ -35,7 +35,10 @@ RESTRICT="!cpudetection? ( bindist )"
BDEPEND="
app-arch/xz-utils
sys-devel/m4
+ sys-devel/flex
+ sys-devel/bison
"
+# https://bugs.gentoo.org/905905
DOCS=( AUTHORS ChangeLog NEWS README doc/configuration doc/isa_abi_headache )
HTML_DOCS=( doc )
diff --git a/sys-apps/portage/portage-3.0.44-r1.ebuild b/sys-apps/portage/portage-3.0.44-r1.ebuild
index f6c5de541..e2df2848c 100644
--- a/sys-apps/portage/portage-3.0.44-r1.ebuild
+++ b/sys-apps/portage/portage-3.0.44-r1.ebuild
@@ -177,6 +177,11 @@ python_prepare_all() {
fi
}
+python_compile() {
+ distutils-r1_python_compile \
+ --executable="${EPREFIX}/usr/bin/${EPYTHON}"
+}
+
python_compile_all() {
local targets=()
use doc && targets+=( docbook )
@@ -195,6 +200,7 @@ python_install() {
# Install sbin scripts to bindir for python-exec linking
# they will be relocated in pkg_preinst()
distutils-r1_python_install \
+ --prefix="${EPREFIX}/usr" \
--system-prefix="${EPREFIX}/usr" \
--bindir="$(python_get_scriptdir)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
@@ -237,7 +243,7 @@ python_install_all() {
}
pkg_preinst() {
- if ! use build; then
+ if [[ -z ${ROOT} ]] && ! use build; then
python_setup
local sitedir=$(python_get_sitedir)
[[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"